Registering for Microsoft ELMS for Imagine Software (2017-2018)

Math & Computer Science Department — Webster University

Students currently enrolled in one of the Math & Computer Science department’s computing courses in
St. Louis may download a variety of free Microsoft software via the department’s ELMS for DreamSpark
web store.

Examples include:
Windows 7 /8 /10 Visual Studio  Project Access Visio  Streets & Trips etc.

Students must be registered and validated in order to download software. Your instructor has requested
an account for each student.

1. Visit the department’s ELMS for DreamSpark web store
http://mercury.webster.edu/wang/msdnaa/

Store webpage:
https://e5.onthehub.com/WebStore/ProductsByMajorVersionList.aspx?ws=1b450bag8-4bb9-e411-9408-
b8ca3a5db7al

2. Click on “Register” in the upper right hand corner of the screen:

Microsoft Imagine X TS

Louis - Mathematics and Computer Science - Microsoft Imagine Premium

3. You will then receive an email in your official Webster email account with further instructions. (Check your junk
folder)
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http://mercury.webster.edu/wang/msdnaa/
https://e5.onthehub.com/WebStore/ProductsByMajorVersionList.aspx?ws=1b450ba8-4bb9-e411-9408-b8ca3a5db7a1
https://e5.onthehub.com/WebStore/ProductsByMajorVersionList.aspx?ws=1b450ba8-4bb9-e411-9408-b8ca3a5db7a1

4. Open the email and click on =
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the link to complete your AT An ot o b ) I o 230
. . N . “
registration. . [ e AN
. WabStoee. Wil I, you can dosnload and acosss a wide range of Microsoft dewwlopes ook, seewrs, 1

aovd platforms & free)
Get Strted Now

To complete the reglstration process, you need to follow just 1 stepl Clicking the registration link
Dedorw will send you 10 3 page where you'll Be asked 1o creste 5 unique gosswond for your scoount
Once that’s complete, you're donel

Click here to comglate your registration

1 yoss ane redBractod Lo your anganization’s infermal sygn-in page, you will seed 1o sign e osing he
credentials prosded by your organization,

5. Enter your first and last name, choose and confirm a password (eg your connections password).
Type the requested text, and select “register”

6. After you see the message that registration has been successfully completed, choose the “Home” link in the
upper right hand corner.

7. Proceed to the Download Procedures on the next page.
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Download instructions for Visual Studio 2017 from MSDN-AA from Webster University

** You will need to carefully follow the directions in this document to be successful. **

1. Make sure that you have completed the registration procedures (page 1)
2. If you signed out after completing registration, follow the procedures on page 6 to sign back in.

3. Select “Developer Tools”

. Popular
from the menu options

Microsoft

Operating Systems N - Sk -
Developer Tools
Servers Visual Studio Ent N Studi B
. isual Studio Enterprise Visual Studio Community .
Microsoft Azure for Students Windows 10 2017 P 2017 i Visual Studio
Applications
Training
All
1] Office
Windows Server 2016 Access 2016 Project 2016 Visio 2016 Windows

4. Then scroll down to select
“Visual Studio 2017
Enterprise”

Visual Studio Enterprise Visual Studio Community

Visual Studio for Mac

2017 2017
=
ﬁ'@TSer\rer
SQL Server 2016 Enterprise _ L Visual Studio Team
SQL Server 2016 Web
Core aLs Foundation Server 2015

5. Add Visual Studio 2017 to
cart

— Visual Studio Enterprise 2017

Enterprise-class development

Toals and services for designing, building and managing complex enterprise
¢ Visual Studio

Choose a language: English

Visual Studio Enterprise 2017 32/64-bit (Multilanguage) - Microsoft Imagine

Available to: Students/Faculty/Staff

Math and Computer Science, Webster University XSuo



6.

Click on Check out Vour Cart

Bonus Offers

Visual Studio Enterprise 2017 32/64-bit (Multilanguage) - Microsoft Imagine - Download Free ®
- Date Added: 2017-08-24 1:40 PM

Subtotal: Free

and conditions associated wr

By placing this order, you agree to all teza {tems. View all terms and conditions.

Back to Shopping

Click on “Download” and

® Your order has been placed and a confirmation email will be sent to you shortly. An invoice you can print is available here. Detailed informatic

be sure to write down the about all of your orders can always be found under Your Account.
product key, as you will
need it in the next a few Details (Order Number: 100560835138)
steps
Downloads

Visual Studio Enterprise 2017 32/64-bit (Multilanguage) - Microsoft Imagine - Download

b O Product Key: Mo

Click on “download” again and be sure to  Order Summary
save the exe file in a location where you

. . Qrder Number: 100560835138
can find it later reer umber

Order Date: 2017-08-24

Download Your Software

prise 2017 32/64-bit (Multilanguage)

Download @

Size: 1 MB

Click on the downloaded exe file to start
installation. Click on “Continue”. The x
installation process will automatically Visual Studio

and will take a few minutes.

To learn more about privacy, see the Microsoft Privacy Statement.

By continuing, you agree to the License Terms.

] )

—_—
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10. On the next screen, be
sure to check “Desktop
development with C++”

and then click on “install”.
The download and
installation process will
follow automatically

Installing — Visual Studio Enterprise 2017 — 1532
Workloads Individual components
Windows (3)

MM Universal Windows Platform development
reate applications for the Universal Windows Platform
HE c lications for the Universal Windows Platf
with C#, VB, JavaScript_or optionally C++.

Language packs

NET desktop development
Build WPF, Windows Forms, and consale applications using
C#, Visual Basic, and F%.

t_,_] Desktop development with C++
Build classic Windows-based applications using the power
of the Visual C++ toolset, ATL, and optional features like...
Web & C15

@ ASPNET and web development

Build web applications using ASP.NET, ASP.NET Core,
HTML, JavaScript, and container development tools.

P Python development

Editing, debugging, interactive development and source
control for Python

Location

C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise

o Azure development

Azure SDK, tools, and projects for developing cloud apps
and creating resources.

S| Nodejs development
Build scalable network applications using Nedejs, an

asynchronous event-driven JavaScript runtime.

By continuing, you agree to the license for the Visual Studio edition you selected. We also offer the ability to download other software with Visual Studio. This software
is licensed separately, as set out in the 3rd Party Notices or in its accompanying license, By continuing, you also agree to those licenses.

Summary

> Visual Studio core editor

+ Desktop development with C++
Included
v Visual C++ core desktop features

Optional
VC++ 2017 v141 toolset (x86,x64)
C++ profiling tools
Windows 10 SDK (10.0.15063.0) for Desktop €
Visual C++ tools for CMake
Visual C++ ATL support
Windows 8.1 SDK and UCRT SDK
Windows XP support for C++
MFC and ATL support (x86 and x64)
C++/CU support
Clang/C2 (experimental)
Modules for Standard Library (experimental)
IncrediBuild - Build Acceleration
Windows 10 SDK (10.0.14393.0)
Windows 10 SDK (10.0.10586.0)
Windows 10 SDK (10.0.10240.0)
VC++ 2015.3 v140 toolset for desktop (x86,x6¢

Total install size:

Ins!

11. Restart your computer once installation process finishes. You may be asked to log in with Azure after restarting, but
you can simply refuse and click on “next”

12. You can choose your
theme, and then start
Visual Studio

Visual Studio

Start with a familiar environment

Development Settings: ‘ General w

[] Apply customizations from the previous version to the
environment selected above,

Choose your color theme

@ Blue () Blue (Extra Contrast) A
) Vi S —
I — I ——
) Dark () Light
4] 4] Visual Studic
— &

You can always change these settings later.

Start Visual Studio
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Getting Started with Visual Studio 2017

In your start menu, find the installed Visual Studio 2017

1. Choose 4] Start Page - Microsoft Visual Studso
File>New—>Project Fle | Edit View Project Debug Team
New »
Open »
€ Start Page
Close
lose Jut
pve Selected item tr
& Swve All Ctris ShiftS
Source Control »
w'lﬁ ' “tri+ P
Account Settings...
B Eat Alt+Fd

Mew Project

2. Choose “Visual C++">
Empty Project >Name
the project—> Click on

IIOK”

b Recent
4 Installed

I Visual C#
I Visual Basic
4 Visual C++
Windows Desktop
General
ATL
Test
I Cross Platform
I Visual F#
& JavaScript
b TypeScript
Game
I+ Other Project Types

b Online

Mot finding what you are locking for?

Open Visual Studic Installer

Name:

Tools Test Analyze Window Help

3 Project... Ctrl+Shift+ N

@ WebSite... Shift+Alt+N

D File. CtrleN
Project From Basting Code...

rted

res in Enterprise 2017
NET Framework

Visusl Studio Team Services

THOTOOTTTT

The projects, solutions and folders you open locally

appear here.

The remote host for Git repostories and other source
control providers will appear on the recent hst of other
devices you've signed in to.

SampleProject]

[.NET Framework 4.6.1

'| Sort by: |Defau\t

Search (Ctrl+E)

1
h Windows Conscle Application

L
‘Windows Desktop Application

Etj‘ Empty Project

Visual C+ Type: Visual C++

Visual C++ application

Visual C++

Location:

| C\Users\siaoyuansuo51isource\repos

Solution:

| Create new solution

Solution name:

SampleProject]

Create directory for solution
D Add to Source Control

An empty project for creating a local

Cancel
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3.

On the right hand side,
right click on “Source
Files” = Click on
“Add->and then “New
ltem”. If you already
have an existing
program, choose
“Existing Item”
instead.

Choose “C++ File” and
name the file

Y & QuickLaunch (Ctrl+Q) Pl @ x
Sign in B
Solution Explorer v 1 x

Search Solution Explorer (Ctrl+;)
&1 Solution ‘SamplePraject1’ (1 project]
4 [ SampleProjecti

P =B References

& External Dependencies
0 Header Files

o Rasl |IIi I;

Solution Explorer BEETHNSRIGIE

Add New Item - SampleProject1

@E- - d B F=R

4 Installed Sort by: | Defaut = Search (Ctrl+E)
4 Visual C++ ) Visual C + Type: Visual C++
Code
Dat: 4
e [H]  HesverFite iy Visual Cos
Resource
Web
c ‘[: o Class Visual C+
Utility
Property Sheets
ATL
HLSL
Graphics
P Online
MName: Source.cpp
Location: |C:\Users\xiaoyuansuo5Tisourcelrepos\SampleProject 1\ SamplePraject 1\ -] Browse...
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Creates a file containing C++ source code
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On the right hand side,
right Click on your
project title, and then
select “Properties”

Choose
Linker->System
Click on the dropdown
menu next to
“SubSystem” and then
choose “Console
(/SubSystem:console)”.
Click on “Apply”, and
then “OK”

Start Programming!

Schution Explorer
@E-| o5 f @ A=R
Search Sohution Explarer {Cirle

] Selution ‘SamplePregect]” (1 preject)

Build

i fui »
Rebuild bependencies
Chean les
View » [Files
Ansbe O

cop

Praject Only .
Retarget Propects
Ovenview
Scope to This

[ HNew Solution Exploner Veew
R Show on Code Map

Profile Guided Optimization »
Build Dependen cies .
Aeld .
B Class Wizard... Ctri+Shifte X
B Manage NuGet Packages...
B Set as Santlp Project
Debug .
Source Control .

H cu Crstat
Pa tri+ ject Properties

X Remeve Del
[ Rensme
Uniload Project SampleProject]
Resean Selutien pes
€ Open Folderin i Explorer sampiebraett S
F Properties AltEnter
Configuration: | Active{Debug) v Platform: | Active(Win32) v Configuration Manager...
|74 Conigenion ropets :
General Minimum Required Version |Not Set
Debuggng Heap Reserve Size Conzole (/SUBSYSTEM:CONSOLE)
VC++ Directonies Hesp Commat Size Windows (/SUBSYSTEM:WINDOWS)
b C/Ces Stack Reserve Size Natrve (/SUBSYSTEM:NATIVE)
4 Linker Stack Commit Size EFl Appication (/SUBSYSTEMEFI_APPLICATION)
General Enable Laege Addresses EFl Boot Service Drver (/SUBSYSTEMEF_BOOT_SERVICE ORIVER)
Input Teseningl Sesver j(FI ROM (/SUBSYSTEMEFI_ROM)
Maniest File Swap Run From CO EF1 Runtirne (/SUBSYSTEM:EFI_RUNTIME_DRIVER)
Debugging Swap Run From Network POSIX {/SUBSYSTEMPOSIX)
it Dviver Nok Set
Optimization
Embedded IDL
Windows Metadata
Advanced
All Opticns
Cemmand Line
b Manifest Tool
b XML Document Generator
b Browse information
b Build Events
b Custom Build Step
b Code Anadysis
| _—
The /SUBSYSTEM option telis the operating system how 1o run the .exe file.The choice of subsystem affects the
| < > entry point symbol (or entry peint function) that the linker will choose.

oK Cancel Apply

Source.cpp

[ SampleProject
1 #include <iostream>
2 using namespace std;
3 Flint main()
4 {
5 cout << "Hello World!™ << endl;
[ return 8;
7 1)
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8. Click on “Build”, and

then “Compile”

9. All potential
Success/Fail messages
will be shown in the
output box on the

bottom of the screen

10.

Click on
“Build”=>"Build
Solution”

11.

SIJ STIPIEIVIELLT T IIIURTE FOUS SR

File Edit View Project Build Debug Tesm Tools Test Analyze
©-0|83-% MMl BuidSolution
Rebuild Solution
Source.cpp € X
Clean Solution

%] SsmpleProject?

using na

4 {
5 cout

6 retu

-

it wai
sl &% Build SampleProject]

Build full program database file for solution
Run Code Analysis on Solution

Rebuild SampleProject]
Clean SampleProject]
Project Only

Profile Guided Optimization
Batch Build...

Configuration Manager...

W Compile

Window  Help
Ctrl+Shift+B iugg« -
bal Scope)
Al+F11
»
»
Ctrl«F7

Show output from:  Build

1>Skipping. ..
1x*Source.cpp

(no

Build started:

relevant changes detected)

Build: 1 succeeded, @ failed, @ up-to-date, @ skipped

Project: SampleProjectl, Configuration: Debug Win32

ﬂ SampleProject] - Microsoft Visual Studic

| E|2a

File Edit View Project Build | Debug Team Tools Test Analyze Window Help
O -0 | 8- B Buid Solution Ctri+Shift+B  pbugger
. SorceeppRElX Rebuild Solution
[ SampleProject] Gy bal Scope)
1 zinclude Build full program database file for solution
2 using nai Run Code Analysis on Solution Alt+F11
i T ;.nt mainl & Build SampleProject]
5 cout Rebuild SampleProject]
" retu Clean SampleProject]
' ¥ Project Only 3
Profile Guided Optimization »
Batch Build...
Configuration Manager...
a Compile CirdsF7
W) SampleProject! - Microsoft Visual Studio
File Edit View Project Build | Debug Team Tools Test Analyze Window Help
©-0|13-% MY BuldSolution Ctrl=Shift+8
e Rebuild Solution
[ SampleProject! Chmn Solion bal Scop
1 #include Busld full program database file for solution
using na Run Code Analysis on Solution Al«F11
4 |5 2“‘ e n:: Build SampleProject!
cout Rebuild SampleProgect]
Gy Clean SampleProject!
! Project Only »
Profile Guided Optimization »
Batch Build...
Configuration Manager...
W Compile Crl=F7
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12.

13.

14.

Now click on “Debug”
and then “Start
without debugging”

Console screen will
show your final output

Be sure to save your
programs by the end.
To do so, click on
“File”>"Save
your_program.cpp”
As...

‘,{I SampleProject] - Microsoft Visual Studio

File Edt View Project Build Debug Team Tools Test

o - SRl - Windows

P
2
2 5 1
il (% SampleProject
4
-3
- using name
- int main()
3 Attach to Process.
-3 i
g cout He Debug Targets
Lo return 9;

Hello

Press

SamnpleProject] - Microsoft Visual Studio

Fle  Eg - Proje Bulld Debug Team
B »
Jpen 0
< 2
jd t ce Control
dd ’
‘e
[ x] ¢
= sve . r
ave Source<pp As
u“ ave A }
Jt f >
B age Setup
- P .
Account Setting
.",EY"’- es »
ecent Proje nd 20f »
[ x] F
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Analyze

Window  Help

» s Debug
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XSuo



